1. WooCommerce Product Table
  2. Troubleshooting

What are the minimum server requirements?

Our plugins are fully tested with the latest versions of PHP, WordPress, WooCommerce and Easy Digital Downloads.

We always recommend running the most up-to-date software, but we also support older versions. Please refer to the list below for the minimum requirements for your web server.

Supported versions

These are the minimum versions we can offer support with our plugins, and for which we guarantee compatibility.

WordPress - 5.0 and up (tested to 5.8.2)
PHP - 7.2 and up (tested to 8.0.13)
Easy Digital Downloads - 2.9 and up (tested to 2.11.3.1). For our EDD plugins.
WooCommerce - 3.7 and up (tested to 5.9.0). For our WooCommerce plugins.

A note on unsupported software

PHP versions 7.3 and below and MySQL versions 5.6 and below are no longer maintained. Using outdated software may expose your site to security vulnerabilities. If your site is running an old version of this software we recommend you upgrade to the latest version. Please contact your web hosting provider if you are unsure how to do this.

You can find information about the health of your website from the Site Health screen in the Dashboard.

PHP 8.1 compatibility

WordPress is not currently compatible with PHP 8.1, so it is not possible to test our plugins with this version of PHP. However, from our analysis there should be no issues with PHP 8.1 once WordPress itself is updated. Support for PHP 8.1 is currently scheduled for WordPress 5.9.

PHP compatibility errors

Customers occasionally report that certain PHP compatibility checkers flag up a problem in one of our plugins. These are usually related to the use of the /e modifier in the preg_replace function.

For example, you might see an error like this:

FOUND 1 ERROR AFFECTING 1 LINE
--------------------------------------------------------------------------------------------
ERROR | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0

You can safely ignore these messages.

These are false positives flagged up by the compatibility checker. While we do use the preg_replace() function in some of our plugins, we don't use the /e modifier. The checker isn't able to correctly distinguish between different uses of the function, and flags up all instances of preg_replace, whether they use /e or not.

Related Articles

Still need help?
If searching the knowledge base hasn't answered your question, please contact support.